use strict;
my $str = 'UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
I\'m going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
**Edit: More precise explanation:**
***editprofile.js***
-- Edit --';
my $regex = qr/([-*]*\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:+\s*[-*]*\s*|[-*]+\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)\s*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}