const regex = /([-*]*\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:+\s*[-*]*\s*|[-*]+\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)\s*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-*]*\\s*\\b(edit|update).*\\b(\\s*#?[0-9]+)?\\s*:+\\s*[-*]*\\s*|[-*]+\\s*\\b(edit|update).*\\b(\\s*#?[0-9]+)?\\s*:*\\s*[-*]+)\\s*', 'gim')
const str = `UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
I'm going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
**Edit: More precise explanation:**
***editprofile.js***
-- Edit --`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}