import re
regex = re.compile(r"([-*]*\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:+\s*[-*]*\s*|[-*]+\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)\s*", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("UPDATE: changed the example to show use,\n\n"
"Edit: Something different\n\n"
"**EDIT** I really mean this one...\n\n"
"Edit #2: \n\n"
"I'm going to edit my question. Better not match any of this update here.\n\n"
"Edit the file to...\n\n"
"Update for anyone who cares:\n\n"
"Update for nobody.\n\n"
"**Edit: More precise explanation:**\n\n"
"***editprofile.js***\n\n"
"-- Edit --")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")