using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"the( the)?";
string substitution = @"";
string input = @"the
the the";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}