use strict;
my $str = 'the
the the';
my $regex = qr/the( the)?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";