const regex = /the( the)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('the( the)?', '')
const str = `the
the the`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);