#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/var\/log\/sites-web\/user\.cluster\.hosting\.ovh\.net-\d\d-\d\d-\d\d\d\d\.log$"
Local $sString = "/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-2022.log" & @CRLF & _
"/var/log/sites-web/user.cluster.hosting.ovh.net-99-02-2022.log" & @CRLF & _
"/var/log/sites-web/user.cluster.hosting.ovh.net-02-99-2022.log" & @CRLF & _
"/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-9999.log" & @CRLF & _
"/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-202.log" & @CRLF & _
"/var/log/sites-web/user.cluster.hosting.ovh.net-02-0-2022.log" & @CRLF & _
"var/log/syslog" & @CRLF & _
"var/log/auth.log" & @CRLF & _
"/var/ossec/logs/alerts/alerts.log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")