re = /^\/var\/log\/sites-web\/user\.cluster\.hosting\.ovh\.net-\d\d-\d\d-\d\d\d\d\.log$/m
str = '/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-99-02-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-99-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-9999.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-202.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-0-2022.log
var/log/syslog
var/log/auth.log
/var/ossec/logs/alerts/alerts.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end