import Foundation
let pattern = #"^\/var\/log\/sites-web\/user\.cluster\.hosting\.ovh\.net-\d\d-\d\d-\d\d\d\d\.log$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-99-02-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-99-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-9999.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-202.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-0-2022.log
var/log/syslog
var/log/auth.log
/var/ossec/logs/alerts/alerts.log
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)