const regex = /^\/var\/log\/sites-web\/user\.cluster\.hosting\.ovh\.net-\d\d-\d\d-\d\d\d\d\.log$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/var\\\/log\\\/sites-web\\\/user\\.cluster\\.hosting\\.ovh\\.net-\\d\\d-\\d\\d-\\d\\d\\d\\d\\.log$', 'gm')
const str = `/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-99-02-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-99-2022.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-9999.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-02-202.log
/var/log/sites-web/user.cluster.hosting.ovh.net-02-0-2022.log
var/log/syslog
var/log/auth.log
/var/ossec/logs/alerts/alerts.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}