import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\sYear\\s\\d{4}[\\w\\s,]+?Date\\s\\d+\\s\\w+\\s\\d{4}";
final String string = "Blah bla blah some text . Blah bla blah some text . 2 Year 2011 Company name , Company disclaimer Date 5 january 2011 Blah blah blah text continues . Blah blah blah text continues Blah blah blah text continues Blah blah blah text continuesBlah blah blah text continuesBlah blah blah text continues";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}