re = /\d+\sYear\s\d{4}[\w\s,]+?Date\s\d+\s\w+\s\d{4}/
str = 'Blah bla blah some text . Blah bla blah some text . 2 Year 2011 Company name , Company disclaimer Date 5 january 2011 Blah blah blah text continues . Blah blah blah text continues Blah blah blah text continues Blah blah blah text continuesBlah blah blah text continuesBlah blah blah text continues'
# Print the match result
str.match(re) do |match|
puts match.to_s
end