use strict;
my $str = 'Blah bla blah some text . Blah bla blah some text . 2 Year 2011 Company name , Company disclaimer Date 5 january 2011 Blah blah blah text continues . Blah blah blah text continues Blah blah blah text continues Blah blah blah text continuesBlah blah blah text continuesBlah blah blah text continues';
my $regex = qr/\d+\sYear\s\d{4}[\w\s,]+?Date\s\d+\s\w+\s\d{4}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}