$re = '/\d+\sYear\s\d{4}[\w\s,]+?Date\s\d+\s\w+\s\d{4}/';
$str = 'Blah bla blah some text . Blah bla blah some text . 2 Year 2011 Company name , Company disclaimer Date 5 january 2011 Blah blah blah text continues . Blah blah blah text continues Blah blah blah text continues Blah blah blah text continuesBlah blah blah text continuesBlah blah blah text continues';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);