using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[0-9])(?=.*[a-z])[a-z0-9\/_+£&@""?!'.,()]*$";
string input = @"alpha1234
alpha1234!
1234alpha
!1234alpha
1234!qwer
alpha
1234";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}