$re = '/^(?=.*[0-9])(?=.*[a-z])[a-z0-9\/_+£&@"?!\'.,()]*$/mi';
$str = 'alpha1234
alpha1234!
1234alpha
!1234alpha
1234!qwer
alpha
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);