import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[0-9])(?=.*[a-z])[a-z0-9\\/_+£&@\"?!'.,()]*$";
final String string = "alpha1234\n"
+ "alpha1234!\n"
+ "1234alpha\n"
+ "!1234alpha\n"
+ "1234!qwer\n"
+ "alpha\n"
+ "1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}