const regex = /^(?=.*[0-9])(?=.*[a-z])[a-z0-9\/_+£&@"?!'.,()]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[0-9])(?=.*[a-z])[a-z0-9\\\/_+£&@"?!\'.,()]*$', 'gmi')
const str = `alpha1234
alpha1234!
1234alpha
!1234alpha
1234!qwer
alpha
1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}