package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(January|February|March|April|May|June|July|August|September|October|November|December)\s+(\d{1,2}),?\s+((?:19|20)\d{2})$`)
var str = `February 2 1976
August 11 2011
november 19 1966
march 11, 1945
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}