re = /^(January|February|March|April|May|June|July|August|September|October|November|December)\s+(\d{1,2}),?\s+((?:19|20)\d{2})$/mi
str = 'February 2 1976
August 11 2011
november 19 1966
march 11, 1945
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end