import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(January|February|March|April|May|June|July|August|September|October|November|December)\\s+(\\d{1,2}),?\\s+((?:19|20)\\d{2})$";
final String string = "February 2 1976\n"
+ "August 11 2011\n"
+ "november 19 1966\n"
+ "march 11, 1945\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}