const regex = /^(January|February|March|April|May|June|July|August|September|October|November|December)\s+(\d{1,2}),?\s+((?:19|20)\d{2})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(January|February|March|April|May|June|July|August|September|October|November|December)\\s+(\\d{1,2}),?\\s+((?:19|20)\\d{2})$', 'gmi')
const str = `February 2 1976
August 11 2011
november 19 1966
march 11, 1945
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}