using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\{[^{}]+\})";
string input = @"{'a':1'}{{'a':1, 'b':2}{'c':3}}{'a':4, 'b':6}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}