// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\{[^{}]+\})").unwrap();
let string = "{'a':1'}{{'a':1, 'b':2}{'c':3}}{'a':4, 'b':6}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}