$re = '/(\{[^{}]+\})/';
$str = '{\'a\':1\'}{{\'a\':1, \'b\':2}{\'c\':3}}{\'a\':4, \'b\':6}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);