const regex = new RegExp('<\\/?[a-z]*>', 'gm')
const str = `Paula kroch durch das <u>Dickicht</u> und hoffte dabei, dass der <b>Tiger</b> sie nicht sah, obwohl ihr <tt>Expeditionshelm</tt> von leuchtend roter Farbe war.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}