re = /<\/?[a-z]*>/m
str = 'Paula kroch durch das <u>Dickicht</u> und hoffte dabei, dass der <b>Tiger</b> sie nicht sah, obwohl ihr <tt>Expeditionshelm</tt> von leuchtend roter Farbe war.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end