# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"Currency"[^,]*,//g;t' <<< "{\"Currency\" : \"Andorran Franc\",\"Code\" : \"ADF\",\"USD/1 Unit\" : \"0.1853\",\"Units/1 USD\" : \"5.3967\"}
{\"Currency\" : \"Andorran Peseta\",\"Code\" : \"ADP\",\"USD/1 Unit\" : \"0.007306\",\"Units/1 USD\" : \"136.8890\"}"