re = /"Currency"[^,]*,/
str = '{"Currency" : "Andorran Franc","Code" : "ADF","USD/1 Unit" : "0.1853","Units/1 USD" : "5.3967"}
{"Currency" : "Andorran Peseta","Code" : "ADP","USD/1 Unit" : "0.007306","Units/1 USD" : "136.8890"}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result