using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Currency""[^,]*,";
string substitution = @"";
string input = @"{""Currency"" : ""Andorran Franc"",""Code"" : ""ADF"",""USD/1 Unit"" : ""0.1853"",""Units/1 USD"" : ""5.3967""}
{""Currency"" : ""Andorran Peseta"",""Code"" : ""ADP"",""USD/1 Unit"" : ""0.007306"",""Units/1 USD"" : ""136.8890""}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}