# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"Currency\"[^,]*,"
test_str = ("{\"Currency\" : \"Andorran Franc\",\"Code\" : \"ADF\",\"USD/1 Unit\" : \"0.1853\",\"Units/1 USD\" : \"5.3967\"}\n"
"{\"Currency\" : \"Andorran Peseta\",\"Code\" : \"ADP\",\"USD/1 Unit\" : \"0.007306\",\"Units/1 USD\" : \"136.8890\"}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.