use strict;
my $str = '<img class="imgbrd lazy" src="/something/iage.png" data-original="/albums/uploadedpics/small1/017246.jpg" border="0">';
my $regex = qr/class="imgbrd lazy"([\s\S]*?)src=".*?"/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";