# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.{5}(?!$)\K/-/gm;t' <<< "OBKFA4F26ORJI3ALFYI3QB4ZN"