const regex = /.{5}(?!$)\K/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.{5}(?!$)\\K', 'gm')
const str = `OBKFA4F26ORJI3ALFYI3QB4ZN`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);