$re = '/.{5}(?!$)\K/m';
$str = 'OBKFA4F26ORJI3ALFYI3QB4ZN';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;