using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{5}(?!$)\K";
string substitution = @"-";
string input = @"OBKFA4F26ORJI3ALFYI3QB4ZN";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}