package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+|\D+|[d+ &])`)
var str = `Mr Smith 10 Rillington Place Exeter Devon
Smith & Sons Ltd. 10 & 12 High Street Sutton Surrey[]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}