const regex = /(\d+|\D+|[d+ &])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+|\\D+|[d+ &])', 'gm')
const str = `Mr Smith 10 Rillington Place Exeter Devon
Smith & Sons Ltd. 10 & 12 High Street Sutton Surrey[]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}