$re = '/(\d+|\D+|[d+ &])/m';
$str = 'Mr Smith 10 Rillington Place Exeter Devon
Smith & Sons Ltd. 10 & 12 High Street Sutton Surrey[]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);