#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(file\/d\/)([a-zA-Z0-9]*)"
Local $sString = "https://drive.google.com/file/d/0B1N6sAoTkkeKeGlxdDZQYUZhbEE/view?usp=sharing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")