package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(file\/d\/)([a-zA-Z0-9]*)`)
var str = `https://drive.google.com/file/d/0B1N6sAoTkkeKeGlxdDZQYUZhbEE/view?usp=sharing`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}