re = /(file\/d\/)([a-zA-Z0-9]*)/
str = 'https://drive.google.com/file/d/0B1N6sAoTkkeKeGlxdDZQYUZhbEE/view?usp=sharing'
# Print the match result
str.match(re) do |match|
puts match.to_s
end