using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\bWord1\b)(?=.*\bWord2\b)(?=.*\bWord3\b)";
string input = @"Word4 Word2 Word1 Word3 Word5 Word7";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}