import Foundation
let pattern = #"^(?=.*\bWord1\b)(?=.*\bWord2\b)(?=.*\bWord3\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Word4 Word2 Word1 Word3 Word5 Word7"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}