use strict;
my $str = 'Word4 Word2 Word1 Word3 Word5 Word7';
my $regex = qr/^(?=.*\bWord1\b)(?=.*\bWord2\b)(?=.*\bWord3\b)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}