re = /^(?=.*\bWord1\b)(?=.*\bWord2\b)(?=.*\bWord3\b)/
str = 'Word4 Word2 Word1 Word3 Word5 Word7'
# Print the match result
str.match(re) do |match|
puts match.to_s
end