$re = '/^define\(\s*[\'"]*(.*?)[\'"]*[\s,]+[\'"]*(.*?)[\'"]*\s*\)/mi';
$str = 'define("My_KEY", "My_Value l");
define(\'My_KEY\', \'My_Value\');
define( \'My_KEY\' , "My_Value" );
define( \'My_KEY\' , \'My\\\'_\\\'Value\' );
define( \'My_KEY\' , "My\'_\'Value" );';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);