re = /^define\(\s*['"]*(.*?)['"]*[\s,]+['"]*(.*?)['"]*\s*\)/mi
str = 'define("My_KEY", "My_Value l");
define(\'My_KEY\', \'My_Value\');
define( \'My_KEY\' , "My_Value" );
define( \'My_KEY\' , \'My\\\'_\\\'Value\' );
define( \'My_KEY\' , "My\'_\'Value" );'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end