import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<nthBase>[+-]?\\d+)(?:\\*?(?<series>n)(?<crementer>[+-]\\d+)?)?$";
final String string = "2n+1\n"
+ "2n\n"
+ "444\n"
+ "-22\n"
+ "+4n\n"
+ "-5*n\n"
+ "-5*n-3\n"
+ "-5n+44\n"
+ "--5\n"
+ "++5\n"
+ "-\n"
+ "+\n"
+ "-6-1\n"
+ "62-1\n"
+ "62n-1\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}