$re = '/^(?<nthBase>[+-]?\d+)(?:\*?(?<series>n)(?<crementer>[+-]\d+)?)?$/m';
$str = '2n+1
2n
444
-22
+4n
-5*n
-5*n-3
-5n+44
--5
++5
-
+
-6-1
62-1
62n-1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);